Alert
AL00346 - Esri Changes to TLS Requirements and Impact to PI Integrator for Esri ArcGIS
2019-01-10
Beginning in February 2019, ArcGIS Online will require TLS 1.2. Therefore, PI Integrator for Esri ArcGIS users must verify
that the client operating system and the web browser support TLS 1.2 for any machine on which either of the following is true:
  • PI Integrator for Esri ArcGIS is installed
  • A user accesses PI Integrator for Esri ArcGIS
Check the operating system and browser documentation to find out if you are using versions that support TLS 1.2.
 
Note: There is a known issue when installing or upgrading PI Integrator for Esri ArcGIS. The installer uses an OLEDB  connection that requires TLS 1.0. If TLS 1.0 is disabled, the installation will fail. The workaround is to temporarily enable TLS 1.0 on the machine where PI Integrator for Esri ArcGIS is installed. Once the software is installed, you can disable TLS 1.0.
 
You can enable and disable TLS at the operating system level by modifying the TLS client and server keys in the Windows Registry.