Submitting your feedback...
Known Issue
211443 - Installer fails when TLS 1.0 is disabled
!This issue is unresolved at this time.
Product Name:
PI Integrator for Esri ArcGIS
Created: 2018-05-18
Modified: 2019-01-04

Affected Versions
* 2017 R2
2.0.0.26732017 SP1
Reported In
Current

Description

If TLS 1.0 is disabled in the registry as per, Disabling TLS 1.0 on your Windows 2008 R2 server – just because you still have one, installation of PI Integrator for Esri ArcGIS ends prematurely with the following error in the log file %PIHOME%\dat\SetupOSIsoft.PIGeoServices.Setup.SelfHost.log:
Calling custom action OSIsoft.PIGeoServices.Setup.Actions!OSIsoft.PIGeoServices.Setup.Actions.CustomActions.VerifySqlRolesFirstInstall
Exception thrown by custom action:
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Data.OleDb.OleDbException: SSL Security error.
Invalid connection string attribute

Workaround

1. Temporarily enable TLS 1.0 in the registry (Enabled=1 for both client and server keys) and reboot the machine to apply the change

2. Install PI Integrator for Esri ArcGIS

3. Disable TLS 1.0 again in the registry (Enabled=0 for both client and server keys) and reboot again to apply the change

* in "Reported In" field indicates an internal build