Release Announcement
PI API 2018 for Windows Integrated Security (WIS) is released
2018-08-16
OSIsoft is pleased to announce the release of PI API 2018 for Windows Integrated Security (WIS).

This release of the PI API addresses the following issues found in PI API 2016 for Windows Integrated Security.
  • Known Issue 125007 - Invalid time stamps can corrupt the bufserv buffers when sending data to PI 3.4.395 or later. As very few PI API applications can send invalid timestamps, this problem is rare. This issue does not affect pibufss.
  • Known Issue 125273 - Incorrect text returned by piut_strerror() for 0 and pitm_servertime.
  • Known Issue 165591 - piba_search() zero timeout returning immediately instead of waiting until a match is found.
  • Known Issue 200782 - pisn_evmestablish() can fail with error - [12151] “Consumer not registered in PI Update” and will not re-register.
PI API for Windows Integrated Security has the following requirements:
  • PI Mappings must be configured on each PI Data Archive server to allow connection from machines using PI API for Windows Integrated Security. This new version of the API does not support PI Trusts or explicit logins; the API application will fail to connect without a valid PI mapping.
  • PI API for Windows Integrated Security requires PI Data Archive 3.4.380.36 or later. Customers should consider upgrading to PI Data Archive 2015 or later to take advantage of additional security enhancements, such as message integrity and privacy.
Refer to the PI API 2018 Release Notes for more details.

Downloads